您的位置:首页 > 其它

POJ 2387 Til the Cows Come Home

2012-09-09 21:25 447 查看
Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various
lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100


Sample Output

90

#include<cstdio>
#include<queue>
#include<cstring>
#include<iostream>
#include<climits>

using namespace std;

#define maxe 2005
#define maxv 1005
struct node
{
    int next ,to, weight;
}edge[maxe*2];
int head[maxv];
int dist[maxv];
int n,m,cnt;

void add(int from,int to,int weight)
{
    edge[cnt].next=head[from];
    edge[cnt].to=to;
    edge[cnt].weight=weight;
    head[from]=cnt++;
}

int spfa(int src,int end)
{
    queue<int>que;
    bool inque[maxv]={false};
    dist[src]=0;
    que.push(src);
    inque[src]=true;
    while(!que.empty())
    {
        int cur=que.front();
        que.pop();
        inque[cur]=false;
        for(int i=head[cur];i!=-1;i=edge[i].next)
        {
            if(dist[edge[i].to]>dist[cur]+edge[i].weight)
            {
                dist[edge[i].to]=dist[cur]+edge[i].weight;
                if(!inque[edge[i].to])
                {
                    que.push(edge[i].to);
                    inque[edge[i].to]=true;
                }
            }
        }
    }
    return dist[end];
}

int main()
{
    cin>>m>>n;
    int u,v,w;
    memset(head,-1,sizeof(head)),cnt=0;
    for(int i=1;i<=n;i++)dist[i]=INT_MAX;
    for(int i=1;i<=m;i++)
    {
        cin>>u>>v>>w;
        add(u,v,w);
        add(v,u,w);
    }
    cout<<spfa(1,n)<<endl;
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: