您的位置:首页 > 其它

POJ---1149 PIGS[dinic()最大流]

2012-09-08 00:52 453 查看
PIGS

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 12578Accepted: 5560
Description

Mirko works on a pig farm that consists of M locked pig-houses and Mirko can't unlock any pighouse because he doesn't have the keys. Customers come to the farm one after another. Each of them has keys to some pig-houses and wants to buy a certain number of pigs.
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold.
More precisely, the procedure is as following: the customer arrives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses.
An unlimited number of pigs can be placed in every pig-house.
Write a program that will find the maximum number of pigs that he can sell on that day.
Input

The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N.
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000.
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line):
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.
Output

The first and only line of the output should contain the number of sold pigs.
Sample Input

3 3
3 1 10
2 1 2 2
2 1 3 3
1 2 6

Sample Output

7

Source

Croatia OI 2002 Final Exam - First day

这题主要是构图比较难,这题以人为节点,如果有公共节点的人就作为前驱



code:

#include<iostream>
using namespace std;

#define MAXN 110
#define inf 0x7fffffff

int n,m;
int cnt[1010];
int pre[1010];
int dis[1010];
int edgenum;

typedef struct edge
{
int from,to,cap;
int next;
}Edge;
Edge edge[MAXN*10];
int head[MAXN];

void addedge(int a,int b,int c)
{
edge[edgenum].from=a,edge[edgenum].to=b,edge[edgenum].cap=c,edge[edgenum].next=head[a],head[a]=edgenum++;
edge[edgenum].from=b,edge[edgenum].to=a,edge[edgenum].cap=0,edge[edgenum].next=head[b],head[b]=edgenum++;
}

int dinic(int st,int et)
{
int sta[1010];
int que[1010];
int ans=0;
while(true)
{
memset(dis,-1,sizeof(dis));
int front=0,tail=0;
int u,v;
dis[st]=0;
que[tail++]=st;
while(front<tail)
{
v=que[front++];
for(int i=head[v];i!=-1;i=edge[i].next)
{
u=edge[i].to;
if(dis[u]==-1&&edge[i].cap>0)
{
dis[u]=dis[v]+1;
que[tail++]=u;
if(u==et)
{
front=tail;
break;
}
}
}
}
if(dis[et]==-1)
break;
int t=0;
int s=st;
while(true)
{
if(s!=et)
{
int i;
for(i=head[s];i!=-1;i=edge[i].next)
if(edge[i].cap>0&&dis[edge[i].from]+1==dis[edge[i].to])
break;
if(i!=-1)
{
sta[t++]=i;
s=edge[i].to;
}
else
{
if(t==0)
break;
dis[edge[sta[--t]].to]=-1;
s=edge[sta[t]].from;
}
}
else
{
int mindis=inf;
int tag;
for(int i=0;i<t;i++)
if(mindis>edge[sta[i]].cap)
{
mindis=edge[sta[i]].cap;
tag=i;
}
ans+=mindis;
for(int i=0;i<t;i++)
{
edge[sta[i]].cap-=mindis;
edge[sta[i]^1].cap+=mindis;
}
s=edge[sta[tag]].from;
t=tag;
}
}
}
return ans;
}

int main()
{
int i,j;
int vst[1010];
edgenum=0;
memset(vst,0,sizeof(vst));
memset(head,-1,sizeof(head));
memset(pre,0,sizeof(pre));
scanf("%d%d",&m,&n);                   //m:猪栏数量;n:人数
int s=0,t=n+1;
for(int i=1;i<=m;i++)
scanf("%d",&cnt[i]);
for(i=1;i<=n;i++)
{
int count,a,cap;
int ans=0;
scanf("%d",&count);
for(j=0;j<count;j++)
{
scanf("%d",&a);
if(!vst[a])
{
ans+=cnt[a];
vst[a]=true;
pre[a]=i;
}
else
{
addedge(pre[a],i,inf);
}
}
if(ans)
addedge(s,i,ans);
scanf("%d",&cap);
addedge(i,t,cap);
}
printf("%d\n",dinic(s,t));
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: