您的位置:首页 > 其它

HDU 1087 Super Jumping! Jumping! Jumping!

2012-09-06 23:23 225 查看
Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.



Input

Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.



Output

For each case, print the maximum according to rules, and one line one case.



Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0




Sample Output

4
10
3动态规划:
子问题:M(i) 表示以ai结尾的最大子序列
递推公式:M(i) = ai + max { M(j) | aj < ai }
最后求出:max { M(i) } 即使答案
LANGUAGE:C++CODE:
#include<iostream>
#include<cstdio>
const int size=1001;
using namespace std;

int main()
{
    __int64 sum[size],max,n;
    int num[size];
    while(cin>>n,n)
    {
        for(int i=0; i<n; i++)
            cin>>num[i];
        for(int i=0; i<n; i++)
            sum[i]=0;
        sum[0]=num[0];
        for(int i=1; i<n; i++)
        {
            max=0;
            for(int j=0; j<i; j++)
            {
                if(num[j]<num[i]&&max<sum[j])
                        max=sum[j];
            }
            sum[i]=max+num[i];
        }
        max=0;
        for(int i=0; i<n; i++)
            if(sum[i]>max) max=sum[i];
        printf("%I64d\n",max);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: