您的位置:首页 > 理论基础 > 计算机网络

Problem 1046 Tempter of the Bone, from http://acm.fzu.edu.cn/problem.php?pid=1046

2012-09-03 19:59 507 查看

Problem 1046 Tempter of the Bone

Accept: 509 Submit: 1504

Time Limit: 1000 mSec Memory Limit : 32768 KB



Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this
maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.



Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will
open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;

'S': the start point of the doggie;

'D': the Door; or

'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.



Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.



Sample Input

4 4 5S.X...X...XD....3 4 5S.X...X....D0 0 0



Sample Output

NOYES



Source

ZOJ 2110

/*需要奇偶减枝,还有明显的条件满足,如可走的时间应该要大于等于要求的时间,至少要走的时间要小于等于剩余的时间。注意dfs的最后返回一个false!*/

什么是奇偶减枝呢?A到B所用时间一定是奇数,因为A到B的距离是奇数;A到C的时间一定是偶数,因为A到C的距离是偶数。这就是奇偶减枝。

A B C

D E F

#include<iostream>
#include<cstdio>
#include<cstdlib>
#define MAX 0x7fffffff
using namespace std;

int n, m, t;
char map[8][8];
int desx, desy;
int dx[] = {0,0,-1,1};
int dy[] = {-1,1,0,0};
bool dfs(int x, int y, int time){

if(x==desx && y==desy){
if(time == t)
return true;
else
return false;
}

if(time>=t)
return false;
if(t-time < abs(x-desx) + abs(y-desy))
return false;
if((t-time-abs(x-desx)-abs(y-desy))%2!=0)
return false;

for(int dir=0;dir<4;++dir){
int ni = x + dx[dir];
int nj = y + dy[dir];
if(map[ni][nj]== '.'){
map[ni][nj] = 'X';
if(dfs(ni, nj, time+1))
return true;
map[ni][nj] = '.';
}
}
return false;

}
int main(){

//freopen("in.txt", "r", stdin);
//freopen("out.txt", "w", stdout);

while(cin>>n>>m>>t, n+m+t){
for(int i=0;i<=n+1;i++){
map[i][0] = 'X';
map[i][m+1] = 'X';
}
for(int i=0;i<=m+1;i++){
map[0][i] = 'X';
map[n+1][i] = 'X';
}
int startx, starty, block = 0;
for(int i=1;i<=n;++i)
for(int j=1;j<=m;++j){
cin>>map[i][j];
if(map[i][j] == 'D')
desx=i,desy=j;
else if(map[i][j] == 'S')
startx=i,starty=j;
else if(map[i][j] == 'X')
block++;
}

if(n*m-block-1<t){
cout<<"NO"<<endl;
continue;
}
map[desx][desy] = '.';
map[startx][starty] = 'X';
if(dfs(startx, starty, 0))
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;
}

//fclose(stdin);
//fclose(stdout);
}





                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: