您的位置:首页 > 编程语言 > Java开发

hdu 1285 确定比赛名次

2012-09-01 18:19 369 查看

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6246    Accepted Submission(s): 2353


[align=left]Problem Description[/align]
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。

 

 

[align=left]Input[/align]
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。

 

 

[align=left]Output[/align]
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。

 

 

[align=left]Sample Input[/align]

4 3
1 2
2 3
4 3

 

 

[align=left]Sample Output[/align]

1 2 4 3  
import java.util.ArrayList;
import java.util.List;
import java.util.PriorityQueue;
import java.util.Scanner;
/**
*  @功能Function Description:  拓扑排序算法
*  @开发环境Environment:       eclipse
*  @技术特点Technique:         利用拓扑排序判断有向图是否有回路
*  @算法
*  @版本Version:               Scanner
*  @作者Author:                follow your dreams
*  @日期Date:                  20120830
*  @备注Notes:                 运行时间:27XXms
*  @链接:                     http://acm.hdu.edu.cn/showproblem.php?pid=1285 */
public class Main {

public static List<ArrayList<Integer>> g;

public static int[] degree;

public static PriorityQueue<Integer> pq;

public static ArrayList<Integer> resultList;

public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n, m, a, b;
while(sc.hasNextInt()) {
n = sc.nextInt();
m = sc.nextInt();
g = new ArrayList<ArrayList<Integer>>(n+1);
initG(n);
degree = new int[n+1];
for(int i=1; i<=m; i++) {
a = sc.nextInt();
b = sc.nextInt();
if(!g.get(a).contains(b)) {//去掉重边
g.get(a).add(b);
degree[b]++;
}
}
resultList = new ArrayList<Integer>(n);
topSort();
showResult();
}
}

public static void showResult() {
int len = resultList.size();
for(int i=0; i<len-1; i++) {
System.out.print(resultList.get(i) + " ");
}
System.out.println(resultList.get(len-1));
}

public static void topSort() {
pq = new PriorityQueue<Integer>();
int len = degree.length;
for(int i=1; i<len; i++) {
if(degree[i] == 0) {
pq.add(i);
}
}
while(!pq.isEmpty()) {
int temp = pq.poll();
resultList.add(temp);
ArrayList<Integer> tempList = g.get(temp);
for(int i=0; i<tempList.size(); i++) {
degree[tempList.get(i)]--;
if(degree[tempList.get(i)] == 0) {
pq.add(tempList.get(i));
}
}
}
}

public static void initG(int n) {
for(int i = 0; i<=n; i++) {
g.add(new ArrayList<Integer>());
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息