您的位置:首页 > 其它

poj_2352 Stars ( 线段树)

2012-09-01 09:53 429 查看
Stars

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 22828
Accepted: 9949
题目链接:http://poj.org/problem?id=2352
Description
Astronomers often examine star maps wherestars are represented by points on a plane and each star has Cartesiancoordinates. Let the level of a star be an amount of the stars that are nothigher and not to the right of the given star. Astronomers
want to know thedistribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the starnumber 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4).And the levels of the stars numbered by 2 and 4 are 1. At this map there areonly one star of the level 0,
two stars of the level 1, one star of the level2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of eachlevel on a given map.
Input
The first line of the input file contains anumber of stars N (1<=N<=15000). The following N lines describecoordinates of stars (two integers X and Y per line separated by a space,0<=X,Y<=32000). There can be only one star at one point of the
plane.Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinatesare listed in ascending order of X coordinate.
Output
The output should contain N lines, one numberper line. The first line contains amount of stars of the level 0, the seconddoes amount of stars of the level 1 and so on, the last line contains amount ofstars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint
This problem has huge input data,use scanf()instead of cin to read data to avoid time limit exceed.
Source
Ural Collegiate ProgrammingContest 1999
解题思路:

这是一个线段树的题目,只需要建树,查询区间,和更新点这几个操作即可。





代码:

#include <iostream>
#include<cstdio>
#include<cstring>

#define maxn 32005
using namespace std;

struct segment
{
    int sum;
    int left;
    int right;
};

segment seg[maxn*4];
int star;
int level[maxn];
void buildTree(int l,int r,int rt)
{
    seg[rt].left=l;
    seg[rt].right=r;
    seg[rt].sum=0;
    if(l==r)
    {
        return ;
    }
    int mid=(l+r)/2;
    buildTree(l,mid,rt*2);
    buildTree(mid+1,r,rt*2+1);
}

//查询区间值
int query(int l,int r,int rt)
{
	int mid=(seg[rt].left+seg[rt].right)/2;
    if(seg[rt].left==l && seg[rt].right==r)
    {
        return seg[rt].sum;
    }
    
    if(l>mid)
    {
        return query(l,r,rt*2+1);
    }
    else if(r<=mid)
    {
        return query(l,r,rt*2);
    }
    else
    {
        return query(l,mid,rt*2)+query(mid+1,r,rt*2+1);
    }
}

void insert(int r,int l,int rt)//区间r到l的值加1
{
    if(seg[rt].left==l && seg[rt].right==r)
    {
        seg[rt].sum++;
        return ;
    }
    int mid=(seg[rt].left+seg[rt].right)/2;
    if(l>mid)
    {
        insert(l,r,rt*2+1);
    }
    else if(r<=mid)
    {
        insert(l,r,rt*2);
    }
    else
    {
        insert(l,mid,rt*2);
        insert(mid+1,r,rt*2+1);
    }
    seg[rt].sum=seg[rt*2].sum+seg[rt*2+1].sum;
}

int main()
{
    scanf("%d",&star);
    int x,y;
    int i;
    buildTree(0,maxn,1);
    memset(level,0,sizeof(level));
    for(i=0;i<star;i++)
    {
        scanf("%d%d",&x,&y);
        int t = query(0,x,1);
        level[t]++;
        insert(x,x,1);
    }
    for(i=0;i<star;i++)
    {
        printf("%d\n",level[i]);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: