您的位置:首页 > 其它

ZOJ 1797 Least Common Multiple

2012-08-30 21:56 260 查看
Least Common Multiple

Time Limit: 2 Seconds Memory Limit: 65536 KB

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15
is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a
single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2

3 5 7 15

6 4 10296 936 1287 792 1

Sample Output
105

10296

题意:求多个数的最大公倍数
思路:最大公约数和最大公倍数的关系,2个数的最大公倍数=2个数相乘/最大公约数
代码:
#include <stdio.h>

long long gcd(long long a,long long b)

{

long long r;

while(b!=0)

{

r=a%b;

a=b;

b=r;

}

return a;

}

long long lcd(long long x,long long y,long long z)

{

return x*y/z;

}

int main()

{

long long N,i;

long long a,b,c,k;

scanf("%lld",&N);

while (N--) {

long long n;

scanf("%lld",&n);

if(n==0)

continue;

scanf("%lld",&a);

if(n==1)

{

printf("%lld\n",a);

continue;

}

scanf("%lld",&b);

k=lcd(a,b,gcd(a,b));

for(i=2;i<n;i++)

{

scanf("%lld",&c);

k=lcd(k,c,gcd(k,c));

}

printf("%lld\n",k);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: