您的位置:首页 > 其它

Game with points(数学,难度中)

2012-08-29 21:09 176 查看
Game with points
Time Limit:500MS

Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
SubmitStatusPracticeSGU
408

Description
Recently Petya has discovered new game with points. Rules of the game are quite simple. First, there is onlyone point
A0 with coordinates (0, 0). Then Petya have to draw N another points. Points must be drawnconsequently and each new point must be connected with exactly one of the previous points by a segment.Let's decribe the game process more
formally. At the i-th step Petya chooses the position of the point
Ai (notnecessarily with integer coordinates). Than he chooses one of the previously drawn points in order to connect it with thepoint
Ai. Lets call this point B. The following conditions must be held:
Point Ai must not coincide with any of the previous points.
Point Ai must not lie on the previously drawn segments.
Segment AiB must not have common points with previously drawn segments, except possibly the point
B.
Segment AiB must not cover any of the previous points, except the point
B.
Length of the segment AiB must not exceed 1. After drawing each point Petya computes two values.
The largest number of segments which share a common point.
The largest euclid distance between some pair of points. After each step Petya gains the score which is equal to the product of these values.Find out which is the maximal score Petya can gain after the whole game.

Input
Input contains single integer number N (0 ≤ N ≤ 1000).

Output
Output the maximal score that Petya can gain. Your answer must be accurate up to 10-3.

Sample Input
sample input

sample output

2

5.000

sample input

sample output

4

20.000

设第i步具有公共点的最大线段数为m, 点间距离最大值为l,则该步所添加的线段要么使m加1,要么使l加1,这样才能确保最终答案最大。当满足

(m + 1) * l >= m * (l + 1)时,使m加1更优,否则使l加1更优。注意特殊情况i = 2,因为在这一步能使m和l同时加1.

此题输出小数有误导成分,实际上答案是整数,再化做小数输出即可。

AC CODE:

//Memory: 935 KB 		Time: 31 MS
//Language: GNU CPP (MinGW, GCC 4) 		Result: Accepted

#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <map>
#define LL long long
#define MAXI 2147483647
#define MAXL 9223372036854775807
#define eps (1e-8)
#define dg(i) cout << "*" << i << endl;
using namespace std;

int main()
{
int l, m, n;
double ans;
while(scanf("%d", &n) != EOF)
{
if(!n) ans = 0.0;
else if(n == 1) ans = 1.0;
else if(n == 2) ans = 5.0;
else
{
ans = 5.0;
l = 2;
m = 2;
while(n-- > 2)
{
if(l <= m)
{
l++;
ans += (1.0 * l * m);
}
else
{
m++;
ans += (1.0 * l * m);
}
}
}
printf("%.3lf\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: