您的位置:首页 > 编程语言 > PHP开发

hdu 1708 Fibonacci String 大水题 2种大水法

2012-08-29 14:27 309 查看

Fibonacci String

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1969    Accepted Submission(s): 690


[align=left]Problem Description[/align]
After little Jim learned Fibonacci Number in the class , he was very interest in it.

Now he is thinking about a new thing -- Fibonacci String .

He defines : str
= str[n-1] + str[n-2] ( n > 1 )

He is so crazying that if someone gives him two strings str[0] and str[1], he will calculate the str[2],str[3],str[4] , str[5]....

For example :

If str[0] = "ab"; str[1] = "bc";

he will get the result , str[2]="abbc", str[3]="bcabbc" , str[4]="abbcbcabbc" …………;

As the string is too long ,Jim can't write down all the strings in paper. So he just want to know how many times each letter appears in Kth Fibonacci String . Can you help him ?

 

[align=left]Input[/align]
The first line contains a integer N which indicates the number of test cases.

Then N cases follow.

In each case,there are two strings str[0], str[1] and a integer K (0 <= K < 50) which are separated by a blank.

The string in the input will only contains less than 30 low-case letters.

 

[align=left]Output[/align]
For each case,you should count how many times each letter appears in the Kth Fibonacci String and print out them in the format "X:N".

If you still have some questions, look the sample output carefully.

Please output a blank line after each test case.

To make the problem easier, you can assume the result will in the range of int.

 

[align=left]Sample Input[/align]

1
ab bc 3

 

[align=left]Sample Output[/align]

a:1
b:3
c:2
d:0
e:0
f:0
g:0
h:0
i:0
j:0
k:0
l:0
m:0
n:0
o:0
p:0
q:0
r:0
s:0
t:0
u:0
v:0
w:0
x:0
y:0
z:0

 

[align=left]Author[/align]
linle
 
题意: 不解释 太水了

#include<stdio.h>
#include<string.h>
int main()
{
int a[30],b[30];
char s1[50],s2[50];
int cas,n,k,i,flag,flag1;
scanf("%d",&cas);
while(cas--)
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
scanf("%s %s %d",s1,s2,&k);
if(k%2==0) flag=1;// 偶数输出a[i] 奇数输出b[i] 具体原因看下面
else flag=0;
for(i=0;i<strlen(s1);i++)
{
a[s1[i]-'a']++;
}
if(k==0)
{
for(i=0;i<26;i++)
printf("%c:%d\n",i+'a',a[i]);
printf("\n");continue;
}
for(i=0;i<strlen(s2);i++)
b[s2[i]-'a']++;
if(k==1)
{
for(i=0;i<26;i++)
printf("%c:%d\n",i+'a',b[i]);
printf("\n");continue;
}
k=k-1;
flag1=1;
while(k--)
{
if(flag1==1)
{
for(i=0;i<26;i++)
{
a[i]=b[i]+a[i];
}
flag1=!flag1;
}
else
{
for(i=0;i<26;i++)
{
b[i]=b[i]+a[i];
}
flag1=!flag1;
}

}
if(flag)
{
for(i=0;i<26;i++)
printf("%c:%d\n",i+'a',a[i]);
}
else
{
for(i=0;i<26;i++)
printf("%c:%d\n",i+'a',b[i]);
}
if(cas!=0)
printf("\n");

}
return 0;
}


自己的方法有点麻烦   看了下别人的代码  哎呦 自己的那叫一个复杂啊

参考代码作者

梦醒之后,灯火阑珊

#include<stdio.h>
#include<string.h>
int ans[50][27];
int main()
{
int T,n,i,j;
char s1[31],s2[31];
scanf("%d",&T);
while(T--)
{
scanf("%s%s%d",s1,s2,&n);
memset(ans,0,sizeof(ans));
for(i=0;s1[i]!=NULL;i++)
ans[0][s1[i]-'a']++;
for(i=0;s2[i]!=NULL;i++)
ans[1][s2[i]-'a']++;
for(i=2;i<=n;i++)
for(j=0;j<26;j++)
ans[i][j]=ans[i-1][j]+ans[i-2][j];
for(i=0;i<26;i++)
printf("%c:%d\n",'a'+i,ans
[i]);
printf("\n");
}
return 0;
}


 
 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息