您的位置:首页 > 其它

ZOJ 1760 Doubles

2012-08-25 18:51 211 查看
Doubles

Time Limit: 2 Seconds Memory Limit: 65536 KB

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in
each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input
The input file will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will
be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

Output
The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input
1 4 3 2 9 7 18 22 0

2 4 8 10 0

7 5 11 13 1 3 0

-1


Sample Output

3

2

0

题意:就是找到一串数字里,一个数字是另一个数字2倍的个数
代码:
#include<stdio.h>

int main()

{

int a[50];

while(scanf("%d",&a[0])){

if(a[0]==-1)

break;

int n=1,t=0;

int i,j;

for(i=1;i<50;i++)

{

scanf("%d",&a[i]);

if(a[i]==0)

{

n=i;

break;

}

}

for(i=0;i<n;i++)

{

for(j=0;j<n;j++)

{

if(a[i]==2*a[j])

t++;

}

}

printf("%d\n",t);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: