您的位置:首页 > 其它

Pku2352 Stars 树状数组

2012-08-25 14:57 309 查看
Stars

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 22795Accepted: 9933
Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given
star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at
one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
Source
Ural Collegiate Programming Contest 1999

代码一定要先查询,在更新。查询的即是小于等于x的点有多少个,就是该点的层数值。

代码:
#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
int lev[32005];
int sum1[32005];
int lowbit(int x){
return x&(-x);
}
void update(int x){
while(x<32002){
sum1[x]++;
x+=lowbit(x);
}
}
int sum(int x){
int s=0;
while(x>0){
s+=sum1[x];
x-=lowbit(x);
}
return s;
}

int main(){
int n;
while(~scanf("%d",&n)){
int x,y,m;
m=n;
//printf("%d\n",n);
memset(lev,0,sizeof(lev));
memset(sum1,0,sizeof(sum1));
while(n--){
scanf("%d%d",&x,&y);
++lev[sum(x+1)];
update(x+1);
}
for(int i=0;i<=m-1;++i)
printf("%d\n",lev[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: