您的位置:首页 > 其它

ZOJ 1405 Tanning Salon

2012-08-24 18:33 232 查看
Tanning Salon

Time Limit: 2 Seconds Memory Limit: 65536 KB

Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave,
thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning.
The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive
integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure
of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.
For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.

Sample Input
2 ABBAJJKZKZ

3 GACCBDDBAGEE

3 GACCBGDDBAEE

1 ABCBCA

0



Sample Output

All customers tanned successfully.

1 customer(s) walked away.

All customers tanned successfully.

2 customer(s) walked away.

题意:就是先输入这个公司有几个床,刚开始都是空的,有人进来就占去,有人出去就减去,若有人过来没位置了
那就没被服务的人加1
思路:
//错误点:1.一定要做个标记,找到的相同的标记为1,若不标记像2 abba这种第2个b还有最后一个a都会多减

//2.我的思路是统计N小于0的情况,但是N小于0并不代表所有的走掉的人数,像-2变为-1,走掉的不是等待的那个客户,而是完成服务的客户,这样

//统计就会出错,那么我们只要统计N小于0且比上一次N还要小的就是走掉的等待的客户

代码:
#include <stdio.h>

#include <math.h>

int main()

{

int N;

char str[200];

while(scanf("%d",&N))

{

if(N==0)

break;

getchar();

int i=0;

int j=0;

int n=0;

int m=0;

scanf("%c",&str[0]);

N--;

for(i=1;i<200;i++)

{

int flag=0;

scanf("%c",&str[i]);

if(str[i]=='\n')

break;

for(j=0;j<i;j++)

{

if(str[j]==str[i])

{

N++;

flag=1;

}

}

if(flag==0)

N--;

if(N<0&&N<m)

n++;

m=N;

}

if(n==0)

printf("All customers tanned successfully.\n");

else

printf("%d customer(s) walked away.\n",n);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: