您的位置:首页 > 其它

ZOJ 1334 Basically Speaking

2012-08-24 09:00 246 查看
Basically Speaking

Time Limit: 2 Seconds Memory Limit: 65536 KB

The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that
it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model
I calculator has informed you that the calculator will have the following neato features:
It will have a 7-digit display.

Its buttons will include the capital letters A through F in addition to the digits 0 through 9.

It will support bases 2 through 16.

Input

The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third
number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.

Output

The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print ``ERROR'' (without the quotes) right
justified in the display.
Sample Input
1111000 2 10
1111000 2 16
2102101  3 10
2102101 3   15
12312 4   2
1A   15 2
1234567 10 16
ABCD 16 15

Sample Output
120
78
1765
7CA
ERROR
11001
12D687
D071

题意:进制的转换
注意:还有用scanf(%s)时,空格不会被读进来
代码:
#include <stdio.h>

#include <string.h>

int main()

{

char str[30];

int b1,b2;

int inta[71];

int len;

int i,j;

inta['0']=0;

inta['1']=1;

inta['2']=2;

inta['3']=3;

inta['4']=4;

inta['5']=5;

inta['6']=6;

inta['7']=7;

inta['8']=8;

inta['9']=9;

inta['A']=10;

inta['B']=11;

inta['C']=12;

inta['D']=13;

inta['E']=14;

inta['F']=15;

while(scanf("%s %d %d",str,&b1,&b2)!=EOF) {

len=strlen(str);

int k=1;

int sum=0;

int m;

i=len-1;

while(i>=0)

{

sum+=inta[str[i]]*k;

k=k*b1;

i--;

}

i=0;

while(sum>0)

{

int temp=sum%b2;

if(temp>=10)

str[i++]=(char)(temp-10+'A');

else

str[i++]=(char)(temp+'0');

sum/=b2;

}

if(i>7)

{

printf(" ERROR\n");

}

else

{

for(m=0;m<7-i;m++)

printf(" ");

for(j=i-1;j>=0;j--)

printf("%c",str[j]);

printf("\n");

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: