您的位置:首页 > 其它

uva 10340 - All in All

2012-08-23 17:13 302 查看
Problem E
All in All
Input:
standard input
Output:
standard output
Time Limit: 2 seconds
Memory Limit:
32 MB
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings
are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether
s is a subsequence of t, i.e. if you can remove characters from
t such that the concatenation of the remaining characters is s.

Input Specification
The input contains several testcases. Each is specified by two strings
s, t of alphanumeric ASCII characters separated by whitespace. Input is terminated by EOF.

Output Specification
For each test case output, if s is a subsequence of
t.
Sample Input
sequence subsequence

person compression

VERDI vivaVittorioEmanueleReDiItalia

caseDoesMatter CaseDoesMatter

Sample Output
Yes

No

Yes

No

#include<stdio.h>
#include<string.h>
int main()
{
char s1[100010],s2[100010];
int i,j;
while (scanf("%s%s",&s1,&s2)==2)
{
for (i=0,j=0;s1[i]!='\0'&&s2[j]!='\0';j++)
if (s1[i]==s2[j]) ++i;
if (s1[i]=='\0') printf("Yes\n");
else printf("No\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: