您的位置:首页 > 其它

HDU-1051Wooden Sticks --贪心

2012-08-23 15:53 393 查看

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6563 Accepted Submission(s): 2707


[align=left]Problem Description[/align]
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

[align=left]Input[/align]
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

[align=left]Output[/align]
The output should contain the minimum setup time in minutes, one per line.

[align=left]Sample Input[/align]

3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1

[align=left]Sample Output[/align]

2 1 3

// 贪心算法---先排序---后选择第一个没有用过的木头一次向后找,用掉所有可以用掉的木头,然后返回第一个没用过的木头继续找
#include<cstdio>
#include<algorithm>
using namespace std;
struct stick
{
int len;
int wei;
}a[5001];
bool used[5001];

bool cmp(stick k1,stick k2)       //按照长度从小到大排序,若长度相同按照重量递增排序
{
if(k1.len==k2.len)
return k1.wei<k2.wei;
else
return k1.len<k2.len;
}

int main()
{
int T,n,i,j,st,count;
bool flag;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(i=0;i<n;++i)
scanf("%d%d",&a[i].len,&a[i].wei);
sort(a,a+n,cmp);
memset(used,false,sizeof(used));
used[0]=true;
st=0;       //记录第一个没有用过的木头
count=0;
while(st<n)
{
++count;
for(i=st+1,j=st,flag=true;i<n;++i)
{
if(used[i])
continue;
if(a[j].len<=a[i].len&&a[j].wei<=a[i].wei)
{
used[i]=true;
j=i;
}
else
{
if(flag)
{
st=i;      //只记录第一个没用过的木头
flag=false;
}
}
}
if(flag)    //说明都用过了
break;
}
printf("%d\n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: