您的位置:首页 > 其它

HDU 1443 Joseph

2012-08-19 22:28 302 查看
Problem Description

The Joseph\\\\\\\'s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every
mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and
m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.


Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.


Output

The output file will consist of separate lines containing m corresponding to k in the input file.


Sample Input

3
4
0



Sample Output

5
30


这个算是约瑟夫坏问题吧,我这个是用数学方法暴力解决的,M从K+1开始穷举,如果穷举到了就返回M咯,还是算蛮简单的;

LANGUAGE:C++

CODE:

#include<stdio.h>

int ans[14]={0};

int joseph(int k)
{
    int cnt,p;
    if(ans[k])return ans[k];
    for(int i=k+1;;i++)
    {
        for(cnt=k<<1,p=0;cnt>k;cnt--)
        {
            p=(p+i-1)%cnt;
            if(p<k)cnt=0;
        }
        if(cnt==k)
        {
            ans[k]=i;
            return i;
        }
    }
    return 0;
}

int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        printf("%d\n",joseph(n));
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: