您的位置:首页 > 运维架构

【hdu】 Pseudoprime numbers 伪素数(快速幂+判定素数)

2012-08-16 15:26 423 查看

Pseudoprime numbers

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 3
[align=left]Problem Description[/align]

Fermat's theorem states that for any prime number p and for any integer
a > 1, ap = a (mod p). That is, if we raise
a to the pth power and divide by p, the remainder is
a. Some (but not very many) non-prime values of p, known as base-a
pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all
a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not
p is a base-a pseudoprime.

 

[align=left]Input[/align]

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing
p and a.

 

[align=left]Output[/align]

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

 

[align=left]Sample Input[/align]

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

 

[align=left]Sample Output[/align]

no
no
yes
no
yes
yes

 

[align=left]Source[/align]
PKU
 

// 8.16.cpp : 定义控制台应用程序的入口点。
//

#include "stdafx.h"

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#define LL long long
using namespace std ;
bool isPrime(int a)
{
for(int i=2;i*i<=a;i++)
if(a%i==0) return false;
return true;
}
LL f(LL a,LL b,LL c)
{
LL k=1;
while(b>=1)
{
if(b&1) k=k*a%c;
a=a*a%c;
b>>=1;
}
return k;
}
int main()
{
LL p,a;
while(scanf("%lld%lld",&p,&a),(p||a))
{
LL res=f(a,p,p);
if(res==a%p&&!isPrime(p))puts("yes");
else puts("no");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  numbers output each input c