您的位置:首页 > 其它

TOJ 1923

2012-08-15 21:25 465 查看
1923. Tanning SalonTime Limit: 1.0 Seconds Memory Limit: 65536K
Total Runs: 924 Accepted Runs: 556

Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning.

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon.

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below.

Sample Input
2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0

Sample Output
All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.

//AC
//既然走的还可以来,那么数组长度就不确定啦,不用string的话,可以while(ch=getchar()!='\n')
#include <iostream>
#include <stack>
#include <cstdlib>
#include <cstring>
using namespace std;
bool vis[27];
int main()
{
int i,j,k,T;
while(cin>>T,T)
{
memset(vis,0,sizeof(vis));
int cur = 0;//已经使用的凳子
int ans = 0;//走的人
string str;
str.clear();
cin>>str;
for(i=0;i<str.length();i++)
{
int index = str[i]-'A';
if(vis[index]==false)
{
if(cur<T)
{
cur++;
vis[index] = true;
}
else
ans++;
}
else
{
vis[index] = 0;//正常还可以继续来,加不加这一句均ac,个人认为应该加,否则,成功离开后再来的话不管有没有位均按没位算
cur--;
}
}
ans >>= 1;//ans肯定为偶数
if(ans == 0)
cout<<"All customers tanned successfully."<<endl;
else
cout<<ans<<" customer(s) walked away."<<endl;
}
//system("pause");
return 0;
}

//这个wa
#include <iostream>
#include <stack>
#include <cstdlib>
#include <cstring>
using namespace std;
int vis[27];
int main()
{
int i,j,k,T;
while(cin>>T,T)
{
memset(vis,0,sizeof(vis));
int cur = 0;//已经使用的凳子
int ans = 0;//走的人
string str;
str.clear();
cin>>str;
for(i=0;i<str.length();i++)
{
int index = str[i]-'A';
if(vis[index]==0)
{
if(cur<T)
{
cur++;
vis[index] = 1;
}
else
{
vis[index] = 2;//失败后继续来的话,仍按一个人 次
ans++;
}
}
else
{
cur--;
vis[index] = 0;//正常还可以继续来
}
}
// ans >>= 1;//ans肯定为偶数
if(ans == 0)
cout<<"All customers tanned successfully."<<endl;
else
cout<<ans<<" customer(s) walked away."<<endl;
}
//system("pause");
return 0;
}

注意:不能用战,因为先占座的人可以比后占座的先走
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: