您的位置:首页 > 其它

HDU 3172 Virtual Friends(并查集)

2012-08-15 20:13 405 查看

Virtual Friends

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1629 Accepted Submission(s): 472


[align=left]Problem Description[/align]
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person's network.

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.

[align=left]Input[/align]
Input file contains multiple test cases.
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

[align=left]Output[/align]
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

[align=left]Sample Input[/align]

1
3
Fred Barney
Barney Betty
Betty Wilma

[align=left]Sample Output[/align]

2
3
4

[align=left]Source[/align]
University of Waterloo Local Contest 2008.09

[align=left]Recommend[/align]
chenrui

题意:给你两个人,他们刚成为朋友,问在这两个人的社交圈里有多少个朋友?提示:朋友的朋友也是你的朋友。
分析:用字典树解决,注意下面这组数据:
1
6
Fred Barney
Barney Betty
Betty Wilma
AAAAA BBBBB
AAAA BBBBB
AAAA Fred
输出结果应是:
2
3
4
2
3
7

#include<iostream>
#include<string>
#include<map>
using namespace std;
#define MAX 100005
int father[MAX],sum[MAX];
int total;
map<string,int>A;//用map来处理人名与数字下标之间的对应关系

int find_set(int x)
{
if(x!=father[x])
father[x]=find_set(father[x]);
return father[x];
}
void union_set(int x,int y)
{
x=find_set(x);
y=find_set(y);
if(x!=y)
{
father[x]=y;
sum[y]+=sum[x];
}
}

int main()
{
int t,n;
string a,b;
while(scanf("%d",&t)!=EOF)
{
while(t--)
{
total=0;
A.clear();
scanf("%d",&n);
while(n--)
{
cin>>a>>b;
if(A.find(a)==A.end())
{
total++;
A[a]=total;
father[total]=total;
sum[total]=1;

}
if(A.find(b)==A.end())
{
total++;
A[b]=total;
father[total]=total;
sum[total]=1;
}
union_set(A[a],A[b]);
int ans=find_set(A[b]);
printf("%d\n",sum[ans]);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: