您的位置:首页 > 其它

HDU Electrical Outlets

2012-08-15 10:38 162 查看

Electrical Outlets

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 877 Accepted Submission(s): 792



[align=left]Problem Description[/align]
Roy has just moved into a new apartment. Well, actually the apartment itself is not very new, even dating back to the days before people had electricity in their houses. Because of this, Roy's apartment has only one single wall outlet,
so Roy can only power one of his electrical appliances at a time.

Roy likes to watch TV as he works on his computer, and to listen to his HiFi system (on high volume) while he vacuums, so using just the single outlet is not an option. Actually, he wants to have all his appliances connected to a powered outlet, all the time.
The answer, of course, is power strips, and Roy has some old ones that he used in his old apartment. However, that apartment had many more wall outlets, so he is not sure whether his power strips will provide him with enough outlets now.

Your task is to help Roy compute how many appliances he can provide with electricity, given a set of power strips. Note that without any power strips, Roy can power one single appliance through the wall outlet. Also, remember that a power strip has to be powered
itself to be of any use.

[align=left]Input[/align]
Input will start with a single integer 1 <= N <= 20, indicating the number of test cases to follow. Then follow N lines, each describing a test case. Each test case starts with an integer 1 <= K <= 10, indicating the number of power
strips in the test case. Then follow, on the same line, K integers separated by single spaces, O1 O2 . . . OK, where 2 <= Oi <= 10, indicating the number of outlets in each power strip.

[align=left]Output[/align]
Output one line per test case, with the maximum number of appliances that can be powered.

[align=left]Sample Input[/align]

3
3 2 3 4
10 4 4 4 4 4 4 4 4 4 4
4 10 10 10 10


[align=left]Sample Output[/align]

7
31
37


思路:只要知道前一个会被后面的那个占一个位置,直到最后一个不会被占。

AC代码:
#include<iostream>
using namespace std;
int main()
{
int t,n,i,a,s;
while(scanf("%d",&t)!=EOF)
{
while(t--)
{
scanf("%d",&n);
s=0;
for(i=1;i<=n;i++)
{
scanf("%d",&a);
if(i==n)s+=a;
else s+=a-1;
}
printf("%d\n",s);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: