您的位置:首页 > 其它

HDU 2710 Max Factor

2012-08-14 22:27 281 查看

Max Factor

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2084 Accepted Submission(s): 658



[align=left]Problem Description[/align]
To improve the organization of his farm, Farmer John labels each of his N (1 <= N <= 5,000) cows with a distinct serial number in the range 1..20,000. Unfortunately, he is unaware that the cows interpret some serial numbers as better
than others. In particular, a cow whose serial number has the highest prime factor enjoys the highest social standing among all the other cows.

(Recall that a prime number is just a number that has no divisors except for 1 and itself. The number 7 is prime while the number 6, being divisible by 2 and 3, is not).

Given a set of N (1 <= N <= 5,000) serial numbers in the range 1..20,000, determine the one that has the largest prime factor.

[align=left]Input[/align]
* Line 1: A single integer, N

* Lines 2..N+1: The serial numbers to be tested, one per line

[align=left]Output[/align]
* Line 1: The integer with the largest prime factor. If there are more than one, output the one that appears earliest in the input file.

[align=left]Sample Input[/align]

4
36
38
40
42


[align=left]Sample Output[/align]

38


思路:我先打表,然后按照打的表,一个除下来,找到最大可以除的质数。

AC代码:

#include<iostream>
using namespace std;
bool isprime[20000];
int prime[20000];
void init()
{
int i,j,num=0;
for(i=0;i<20000;i++)isprime[i]=1;
for(i=2;i<20000;i++)
{
if(isprime[i])
{
prime[num++]=i;
for(j=2;j*i<20000;j++)
{
isprime[j*i]=0;
}
}
}
}
int main()
{
int t,a,i,b,n,max;
init();
while(scanf("%d",&t)!=EOF)
{
max=-99999;
while(t--)
{
scanf("%d",&a);
b=1;
for(i=0;prime[i]<=a;i++)
{
if(a%prime[i]==0)
if(b<prime[i])b=prime[i];
}
if(max<b){max=b;n=a;}
}
printf("%d\n",n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: