您的位置:首页 > 其它

HDU 2123 An easy problem

2012-08-14 09:52 363 查看

An easy problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3474 Accepted Submission(s): 2452



[align=left]Problem Description[/align]
In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the ith row and jth column should be the product(乘积) of i and j.

[align=left]Input[/align]
The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.

[align=left]Output[/align]
For each test case, print out the multiply table.

[align=left]Sample Input[/align]

2
1
4


[align=left]Sample Output[/align]

1
1 2 3 4
2 4 6 8
3 6 9 12
4 8 12 16

HintThere is no blank space at the end of each line.


思路:先打表,然后再控制输出就行了。

AC代码:

#include<iostream>
using namespace std;
int a[10][10];
int main()
{
int t,i,j,n;
for(i=1;i<10;i++)
{a[1][i]=a[i][1]=i;}
for(i=2;i<10;i++)
for(j=2;j<10;j++)
a[i][j]=a[i][1]*a[1][j];
while(scanf("%d",&t)!=EOF)
{
while(t--)
{
scanf("%d",&n);
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
if(j==n)
printf("%d\n",a[i][j]);
else printf("%d ",a[i][j]);
}
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: