您的位置:首页 > 其它

POJ 2352 Stars

2012-08-14 07:40 337 查看
Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know
the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars
are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5


Sample Output

1
2
1
1
0

题目大意: 有n个星星, 现在分别给出它们按y递增的坐标,每个星星有一个等级(该星星的等级是x坐标和y坐标都不大于该星的星星数),先要求出每个等级的星星有多少个

这个是线段树第一次写,详解请关注大神博客:

http://blog.csdn.net/ulquiorra0cifer/article/details/7769675

LANGUAGE:C

CODE:

#include<stdio.h>
#include<string.h>
#define max 33000

struct
{
    int l,r,sum;
}tree[max<<2];

void build(int l,int r,int idx)
{
    int mid=(l+r)>>1;//get the midle
    tree[idx].sum=0;//init sum
    if(l==r)//at same point
    {
        tree[idx].l=tree[idx].r=r;
        return ;
    }
    tree[idx].l=l;tree[idx].r=r;
    build(l,mid,idx<<1);//build left subtree
    build(mid+1,r,idx<<1|1);//build(mid+1,r,idx*2+1);build right subtree
}

void add(int l,int r,int idx)
{
    int mid=(tree[idx].l+tree[idx].r)>>1;
    if(tree[idx].l==l&&tree[idx].r==r)//if find the segment
    {
        tree[idx].sum++;//current segement
        return ;
    }
    if(l>mid)
	    add(l,r,idx<<1|1);//if the segement at root's right:add to the right subtree
    else if(r<=mid)add(l,r,idx<<1);//if the segement at root's left:add to the left subtree
    else
    {
        add(l,mid,idx<<1);//add to the left subtree
        add(mid+1,r,idx<<1|1);//add to the right subtree
    }
    tree[idx].sum=tree[idx<<1|1].sum+tree[idx<<1].sum;//get sum
}

int query(int l,int r,int idx)
{
    int mid=(tree[idx].l+tree[idx].r)>>1;
    if(tree[idx].l==l&&tree[idx].r==r)//if find the segement,return sum;
        return tree[idx].sum;
    if(l>mid)
        return query(l,r,idx<<1|1);//return right subtree's sum;
    else if(r<=mid)
        return query(l,r,idx<<1);//return left subtree's sum;
    else
        return query(l,mid,idx<<1)+query(mid+1,r,idx<<1|1);//return the sum of subtree's sum;
}

int main()
{
    int i,n,x,y,lev[max];
    while(scanf("%d",&n)!=EOF)
    {
        memset(lev,0,sizeof(lev));
        build(0,max,1);
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            lev[query(0,x,1)]++;
            add(x,x,1);
        }
        for(i=0;i<n;i++)
            printf("%d\n",lev[i]);
    }
    return 0;
}





                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: