您的位置:首页 > 其它

POJ The Suspects

2012-08-13 20:24 218 查看
http://poj.org/problem?id=1611

The Suspects

Time Limit: 1000MSMemory Limit: 20000K
Total Submissions: 15632Accepted: 7470
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are
many student groups. Students in the same group intercommunicate with
each other frequently, and a student may join several groups. To prevent
the possible transmissions of SARS, the NSYSU collects the member lists
of all student groups, and makes the following rule in their standard
operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects
when a student is recognized as a suspect. Your job is to write a
program which finds all the suspects.
Input

The
input file contains several cases. Each test case begins with two
integers n and m in a line, where n is the number of students, and m is
the number of groups. You may assume that 0 < n <= 30000 and 0
<= m <= 500. Every student is numbered by a unique integer between
0 and n−1, and initially student 0 is recognized as a suspect in all
the cases. This line is followed by m member lists of the groups, one
line per group. Each line begins with an integer k by itself
representing the number of members in the group. Following the number of
members, there are k integers representing the students in this group.
All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003

简单的并查集 直接贴代码

View Code

#include<stdio.h>
int father[30100] ,count[30100];
void Init(int n){
for(int i=0;i<n;i++)
father[i] = i , count[i] = 1 ;
}
int find(int x){
if(x != father[x])
father[x] = find(father[x]) ;
return father[x] ;
}
int Union(int x,int y){
x = find(x) ;
y = find(y) ;
if(x != y)    count[x] += count[y] ;
return father[y] = x ;
}
int main(){
int n,m;
while(scanf("%d%d",&n,&m) , n){
Init(n) ;
while(m--){
int num ;
scanf("%d",&num);
int x ;
scanf("%d",&x) ;
while(--num) {
int y ;
scanf("%d",&y) ;
x = Union(x,y) ;
}
}
printf("%d\n",count[find(0)]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: