您的位置:首页 > 其它

【hdu - 1069 Monkey and Banana(动态规划,被坑死。一遍AC)】

2012-08-08 15:12 411 查看

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4087 Accepted Submission(s): 2112


[align=left]Problem Description[/align]
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

[align=left]Input[/align]
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

[align=left]Output[/align]
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

[align=left]Sample Input[/align]

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

[align=left]Sample Output[/align]

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

[align=left]Source[/align]
University of Ulm Local Contest 1996

[align=left]Recommend[/align]
JGShining

// Project name : 1069 ( Monkey and Banana )
// File name    : main.cpp
// Author       : iCoding
// E-mail       : honi.linux@gmail.com
// Date & Time  : Wed Aug  8 14:39:00 2012

#include <iostream>
#include <stdio.h>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;

/*************************************************************************************/
/* data */
#define MAXN 40

class Block
{
public:
int x;
int y;
int height;
/*x <= y*/
void manage();
void setValue(int x, int y, int height);
void showMap();
};

int n;
Block iMap[MAXN*3];

int iSum[MAXN*3];

/*************************************************************************************/
/* procedure */
void Block::manage()
{
if (x > y)
{
int tmp;
tmp = x;
x   = y;
y   = tmp;
}
}

void Block::setValue(int x, int y, int height)
{
this -> x      = x;
this -> y      = y;
this -> height = height;
}

void Block::showMap()
{
cout << x << " " << y << " - " << height << endl;
}

bool cmp(Block a, Block b)
{
if ((a.x >= b.x && a.y >= b.y) || ((a.x * a.y) >= (b.x * b.y)))
{
return true;
}
else
{
return false;
}
}

void iInit()
{
for (int i = 0; i < n; i++)
{
int a, b, c;
cin >> a >> b >> c;
iMap[i*3]  .setValue(a, b, c);
iMap[i*3+1].setValue(b, c, a);
iMap[i*3+2].setValue(c, a, b);
iMap[i*3]  .manage();
iMap[i*3+1].manage();
iMap[i*3+2].manage();
}
sort(iMap, iMap + 3 * n, cmp);
}

void debug()
{
for (int i = 0; i < n * 3; i++)
{
iMap[i].showMap();
}
}

bool iCanPut(Block bottom, Block up)
{
if (bottom.x > up.x && bottom.y > up.y)
{
return true;
}
else
{
return false;
}
}

void iDynamicProgramming()
{
for (int i = 0; i < 3 * n; i++)
{
int iMax = 0;
for (int j = 0; j < i; j++)
{
if (iCanPut(iMap[j], iMap[i]) && iSum[j] > iMax)
{
iMax = iSum[j];
}
}
iSum[i] = iMap[i].height + iMax;
}
}

void iShowResult()
{
int iMax = 0;
for (int i = 0; i < 3 * n; i++)
{
if (iSum[i] > iMax)
{
iMax = iSum[i];
}
}
cout << iMax << endl;
}

/*************************************************************************************/
/* main */
int main()
{
int iCaseCount = 0;
while (cin >> n && n)
{
iCaseCount++;
cout << "Case " << iCaseCount << ": maximum height = ";
iInit();
//debug();
iDynamicProgramming();
iShowResult();
}
return 0;
}

// end
// Code by Sublime text 2
// iCoding@CodeLab
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: