您的位置:首页 > 其它

POJ 1163 The Triangle

2012-08-05 22:45 323 查看
Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle,
all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5


Sample Output
30

这个题是求在这个三角中,每一层拿一个数,使得和最大,输出这个最大和;

动态规划:状态是从左右孩子中取一个数加起来最大,肯定不能从上面往下面取;

我们可以从倒数第二层的节点作为父亲一直加到顶,这时最顶上的一定是最大值;

LANGUAGE:C

CODE:

#include<stdio.h>
#define max(a,b) a>b?a:b
int main()
{
    //freopen("in.txt","r",stdin);
    int n,i,j;
    int num[101][101],f[99001];
    scanf("%d",&n);
    for(i=1;i<=n;i++)
        for(j=1;j<=i;j++)
            scanf("%d",&num[i][j]);
    for(i=1;i<=n;i++)
        f[i]=num
[i];
    for(i=n-1;i>=1;i--)
        for(j=1;j<=i;j++)
            f[j]=max(f[j]+num[i][j],f[j+1]+num[i][j]);
    printf("%d\n",f[1]);
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: