您的位置:首页 > 其它

杭电acm1020 Encoding

2012-08-02 21:48 351 查看
杭电acm1020

Encoding

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 16302 Accepted Submission(s): 6948



[align=left]Problem Description[/align]
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

[align=left]Input[/align]
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only
'A' - 'Z' and the length is less than 10000.

[align=left]Output[/align]
For each test case, output the encoded string in a line.

[align=left]Sample Input[/align]

2ABCABBCCC


[align=left]Sample Output[/align]

ABCA2B3C


[align=left]Author[/align]
ZHANG Zheng

[align=left]Recommend[/align]
JGShining

代码如下:

#include <iostream>

#include <string>

using namespace std;

int main()

{

int inNum;

int szLength;

char p[10000];

if(cin>>inNum && 1 <= inNum <=100)

{

while(inNum--)

{

scanf("%s",&p);

szLength = strlen(p) <= 10000 ? strlen(p) : 0 ;

if(szLength==0)

break;

int i,k=0;

for(i=0;i<szLength;i++)

{

if(p[i]>='A' && p[i]<='Z')

{

if(p[i]!=p[i+1])//如果不同的话,直接输出

{

cout<<p[i];

}

else//如果相同,则计数

{

k = i;

while(p[i]==p[i+1])i++;

cout<<(i-k+1)<<p[k];//输出多少个相同,注意是连续相同的

}

}

}

cout<<endl;

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: