您的位置:首页 > 其它

【KMP】 hdu3336 Count the string

2012-08-02 11:28 411 查看


Count the string


http://acm.hdu.edu.cn/showproblem.php?pid=3336

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"

The prefixes are: "a", "ab", "aba", "abab"

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1
4
abab


Sample Output

6


题意:给以字符串 计算出以前i个字符为前缀的字符中 在主串中出现的次数和

如: num(abab)=num(a)+num(ab)+num(aba)+num(abab)=2+2+1+1=6;

题解:next[i]记录的是 长度为i 不为自身的最大首尾重复子串长度 num[i]记录长度为next[i]的前缀所重复出现的次数

#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 200005
#define mod 10007
int next[MAX],num[MAX];
char s[MAX];
void get_next()
{
int i=0,j=-1;
next[0]=-1;
for(; s[i];)
if(j==-1||s[i]==s[j])
{
++i;
++j;
next[i]=j;
}
else  j=next[j];
}
int main()
{
int t,n;
scanf("%d",&t);
for(;t--;)
{
int summ=0;
memset(num,0,sizeof(num));
scanf("%d",&n);
scanf("%s",s);
get_next();
for(int i=1;i<=n;++i)
num[next[i]]=(num[next[i]]+1)%mod;
for(int i=1;i<=n;++i)
if(num[i])
summ=(summ+num[i]+1)%mod;
else
summ=(summ+1)%mod;
printf("%d\n",summ);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: