您的位置:首页 > 大数据 > 人工智能

【KMP】 hdu1867 A + B for you again

2012-08-02 10:41 211 查看


A + B for you again


http://acm.hdu.edu.cn/showproblem.php?pid=1867

Problem Description

Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf”
and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.

Input

For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.

Output

Print the ultimate string by the book.

Sample Input

asdf sdfg
asdf ghjk


Sample Output

asdfg
asdfghjk


#include<cstdio>
#include<cstring>
using namespace std;
#define MAX 100005
int next[MAX];
void get_next(char *t)
{
int i=0,j=-1;
next[0]=-1;
for(; t[i];)
if(j==-1||t[i]==t[j])
{
++i;
++j;
next[i]=j;
}
else  j=next[j];
}
int kmp(char *s,char *t)
{
int i=0,j=0;
get_next(t);
int n=strlen(s),m=strlen(t);
for(; i<n&&j<m;)
if(j==-1||s[i]==t[j])
++i,++j;
else
j=next[j];
if(i>=n)
return j;
return 0;
}
int main()
{
char s[MAX],t[MAX];
for(; ~scanf("%s%s",s,t);)
{
int x=kmp(s,t);
int y=kmp(t,s);
if(x==y)
{
if(strcmp(s,t)>0)
{
printf("%s",t);
printf("%s\n",s+x);
}
else
{
printf("%s",s);
printf("%s\n",t+x);
}
}
else if(x>y)
{
printf("%s",s);
printf("%s\n",t+x);
}
else
{
printf("%s",t);
printf("%s\n",s+y);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: