您的位置:首页 > 其它

DP状态压缩:Most Powerful

2012-08-02 10:26 190 查看
Most PowerfulTime Limit:2000MS Memory Limit:65536KB 64bit
IO Format:
%lld & %llu
SubmitStatus

Description

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms
perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th
line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2

0 4

1 0

3

0 20 1

12 0 1

1 10 0

0

Sample Output

4

22

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>

using namespace std;

int p[15][15];
int ps[1<<11];

int main(){
int n, i, j;
while(cin >> n && n){
for(i = 0; i < n; i ++){
for(j = 0; j < n; j ++){
scanf("%d", &p[i][j]);
}
}
int allS = 1 << n;
int curS;
memset(ps, 0, sizeof(ps));
for(curS = 0; curS < allS; curS ++){
for(i = 0; i < n; i ++){
if(curS & (1 << i))
continue;
for(j = 0; j < n; j ++){
if(j == i)
continue;
if(curS & (1 << j))
continue;
int newS = curS + (1<<j);
ps[newS] = max(ps[newS], ps[curS] + p[i][j]);
}
}
}
int ans = 0;
for(i = 0; i < allS; i ++){
if(ps[i] > ans)
ans = ps[i];
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: