您的位置:首页 > 其它

poj 2243 Knight Moves

2012-08-02 03:49 246 查看
Knight Moves

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8612Accepted: 4934
Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of
the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.
Input

The input will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.
Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".
Sample Input
e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output
To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

Source

Ulm Local 1996

一如既往的借鉴大神们的代码,然后小小注释一番,然后算是入门了吧

//*********************************************
//               poj 2243
//*********************************************
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
char a[5],b[5];
int x1,x2,y1,y2;
int dist[10][10],qx[100],qy[100];
int dx[] = { -1, -2, -2, -1, 1, 2, 2, 1};
int dy[] = { -2, -1, 1, 2, 2, -1, 1, -2};

int main()
{
    int x,y,nx,ny,front,rear;
    while(cin>>a>>b)
    {
        x1=a[0]-'a';
        y1=a[1]-'1';
        x2=b[0]-'a';
        y2=b[1]-'1';
        memset(dist,-1,sizeof(dist));
        dist[x1][y1]=0;//初始位置
        front=rear=0;//此时队列为空
        qx[rear]=x1;
        qy[rear]=y1;
        rear++;//将初始位置的坐标赋值到数组
        while(front<rear)//队列不为空
        {
            x=qx[front];//方便撒
            y=qy[front];
            if(x==x2&&y==y2)
            break;
            front++;
            for(int i=0;i<8;i++)
            {
                nx=x+dx[i];
                ny=y+dy[i];
                if(dist[nx][ny]<0&&nx>=0&&nx<8&&ny>=0&&ny<8)//判断没走过,且在边界范围内
                {
                    dist[nx][ny]=dist[x][y]+1;//步数加1           0   1   2   3   4   5   6 
                    qx[rear]=nx;//将当前坐标赋值到队列    qx:   x1  nx   ...
                    qy[rear]=ny;//                           qy:  y1  ny   ...
                    rear++;
                }
            }
        }
        int step=dist[x2][y2];//像是一张手似的伸的很长,然后直接就往回看有多少步
        printf("To get from %s to %s takes %d knight moves.\n",a,b,step);
    }
    return 0;
}


其实BFS没想象中那么难,虽然我还是比较菜......
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: