您的位置:首页 > 产品设计 > UI/UE

POJ 1679 The Unique MST

2012-08-01 23:22 267 查看
Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:

1. V' = V.

2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all
the edges in E'.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a
triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2


Sample Output

3
Not Unique!

题意:判断最小生成树是否唯一用PRIM算法来判断,当我们扩展一个节点u时,得到最小边min,然后判断在已经扩展的集合中是否有大于1条边权值等于min,如果有则最小生成树不唯一,反之唯一。CODE:
#include<stdio.h>
const int INF=1<<30;
int n,m;
int matrix[105][105];
int dist[105];
int  prim()
{

    int u,k,ans=0,flag=0;
    char used[105]={0};
    for(int i=1; i<=n; i++)
    {
        dist[i]=matrix[1][i];
    }
    used[1]=1;
    for(int i=1; i<n; i++)
    {
        int min=INF;
        for(int j=1; j<=n; j++)
        {
            if(!used[j]&&dist[j]<min)
            {
                min=dist[j];
                u=j;
            }
        }
        k=0;
        for(int j=1; j<=n; j++)
        {
            if(used[j]&&min==matrix[u][j])k++;
        }
        used[u]=1;
        if(k>1)
        {
                return -1;
        }
        ans+=min;
        for(int j=1; j<=n; j++)
            if(!used[j]&&matrix[u][j]<dist[j])dist[j]=matrix[u][j];
    }
    return ans;
}
int main()
{
    //freopen("in.txt","r",stdin);
    int tCase,ans;
    scanf("%d",&tCase);
    while(tCase--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=n; j++)matrix[i][j]=INF;
        for(int i=1; i<=m; i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            matrix[u][v]=matrix[v][u]=w;
        }
        ans= prim();
        if(ans==-1)printf("Not Unique!\n");
        else printf("%d\n",ans);
    }
    return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: