您的位置:首页 > 其它

HDU 1078 FatMouse and Cheese【记忆化搜索】

2012-07-31 18:48 375 查看
[align=left]Problem Description[/align]
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0).
He eats up the cheese where he stands and then runs either horizontally or
vertically to another location. The problem is that there is a super Cat named
Top Killer sitting near his hole, so each time he can run at most k locations to
get into the hole before being caught by Top Killer. What is worse -- after
eating up the cheese at one location, FatMouse gets fatter. So in order to gain
enough energy for his next run, he has to run to a location which have more
blocks of cheese than those that were at the current hole.

Given n, k,
and the number of blocks of cheese at each grid location, compute the maximum
amount of cheese FatMouse can eat before being unable to move.

[align=left]Input[/align]
There are several test cases. Each test case consists
of

a line containing two integers between 1 and 100: n and k
n
lines, each with n numbers: the first line contains the number of blocks of
cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number
of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The
input ends with a pair of -1's.

[align=left]Output[/align]
For each test case output in a line the single integer
giving the number of blocks of cheese collected.

[align=left]Sample Input[/align]

3 1
1 2 5
10 11 6
12 12 7
-1 -1


[align=left]Sample Output[/align]

37

思路

就是一道DP题目但是深搜占主导位置,并且和滑雪(POJ1080)那道题很像,记忆化DP。

题意是说:小老鼠可以水平或者竖直的跳最多K不但是到达的每个位置上的奶酪要比之前来时的位置上的多,问小老鼠最多能得到多少奶酪。

思路:选出水平竖直的能到达位置的最大值,状态转与方程为:

dp[x][y]=max{dp[x+j*director][y+j*director]}+a[x][y] ;其中1=<j<=k(可跳的步数)

源码

#include<stdio.h>

#include<string.h>

#include<algorithm>

using namespace std;

#define N 105

int a[N][N], dp[N][N];

int dir[4][2]={{0, 1}, {1, 0}, {-1, 0}, {0, -1}};

int m, k;

int safe(int xxx, int yyy)

{

if(xxx>=0&&xxx<m&&yyy>=0&&yyy<m)

return 1;

return 0;

}

int dfs(int x, int y)

{

int i, j, maxnum=0;

if(dp[x][y]>0)

return dp[x][y];

for(i=0; i<4; i++)

{

for(j=1; j<=k; j++)

{

int xx=x+dir[i][0]*j;

int yy=y+dir[i][1]*j;

if(safe(xx, yy)&&a[xx][yy]>a[x][y])

{

int temp=dfs(xx, yy);

if(maxnum<temp)

maxnum=temp;

}

}

}

dp[x][y]=maxnum+a[x][y];

return dp[x][y];

}

int main()

{

int i, j;

while(scanf("%d%d", &m, &k)!=EOF)

{

if(m==-1&&k==-1)

break;

memset(a, 0, sizeof(a));

memset(dp, 0, sizeof(dp));

for(i=0; i<m; i++)

for(j=0; j<m; j++)

scanf("%d", &a[i][j]);

printf("%d\n", dfs(0, 0));

}

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: