您的位置:首页 > 其它

HDU 1505 City Game【矩阵的最大面积】

2012-07-31 15:49 309 查看
[align=left]Problem Description[/align]
Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid
of equal square units.The rent paid for each unit on which you're building
stands is 3$.

Your task is to help Bob solve this problem. The whole city
is divided into K areas. Each one of the areas is rectangular and has a
different grid size with its own length M and width N.The existing occupied
units are marked with the symbol R. The unoccupied units are marked with the
symbol F.

[align=left]Input[/align]
The first line of the input contains an integer K –
determining the number of datasets. Next lines contain the area descriptions.
One description is defined in the following way: The first line contains two
integers-area length M<=1000 and width N<=1000, separated by a blank
space. The next M lines contain N symbols that mark the reserved or free grid
units,separated by a blank space. The symbols used are:

R – reserved
unit

F – free unit

In the end of each area description there is a
separating line.

[align=left]Output[/align]
For each data set in the input print on a separate
line, on the standard output, the integer that represents the profit obtained by
erecting the largest building in the area encoded by the data set.

[align=left]Sample Input[/align]

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

[align=left]Sample Output[/align]

45
0

思路

方法:子矩阵1的加强版,将一维的状态转换为二维的状态,即再上一基础上加以个for循环,并且R置为F时置为在前行的基础上+1,求出最大面积。

源码

#include<string.h>

#include<stdio.h>

int f[1003][1003], left[1003], right[1003];

int main()

{

int m, n, i, j, k, T, t;

scanf("%d", &T);

char ch[5];

while(T--)

{

scanf("%d%d", &m, &n);

//getchar();

memset(f, 0, sizeof(f));

for(i=1; i<=m; i++)

for(j=1; j<=n; j++)

{

scanf("%s", ch);

if(ch[0]=='F')

f[i][j]=1+f[i-1][j];

}

int area=0;

for(k=1; k<=m; k++)

{

for(i=1; i<=n; i++)

{

left[i]=right[i]=i;

}

for(i=2; i<=n; i++)

{

int temp=i;

while(f[k][temp-1]>=f[k][i]&&temp>1)

temp=left[temp-1];

left[i]=temp;

}

for(i=n-1; i>0; i--)

{

int temp=i;

while(f[k][temp+1]>=f[k][i]&&temp<n)

temp=right[temp+1];

right[i]=temp;

}

for(i=1; i<=n; i++)

{

if((right[i]-left[i]+1)*f[k][i]>area)

area=(right[i]-left[i]+1)*f[k][i];

}

}

printf("%d\n", area*3);

getchar();

}

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: