您的位置:首页 > 其它

hdu 1016 Prime Ring Problem

2012-07-30 10:49 246 查看


Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 13451 Accepted Submission(s): 6099



Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.





Input

n (0 < n < 20).



Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.



Sample Input

6
8




Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2




Source

Asia 1996, Shanghai (Mainland China)



Recommend

JGShining

lrj的入门经典里的暴力求解法中有提到。。。。。不废话了:


#include <stdio.h>
#include <string.h>
int vis[1000],prime[1000],a[1000],n,cases=1;
void fuck()
{
    int i,j;
    for(i=2;i<1000;i++)
    {
        if(!prime[i])
        for(j=i*i;j<1000;j+=i)
        prime[j]=1;
    }
    return ;
}
void dfs(int cur)
{
    if(cur==n&&!prime[1+a[n-1]])
    {
        for(int i=0;i<n-1;i++)
        printf("%d ",a[i]);
        printf("%d\n",a[n-1]);
        return;
    }
    for(int i=2;i<=n;i++)
    if(!vis[i]&&!prime[i+a[cur-1]])
    {
        a[cur]=i;
        vis[i]=1;
        dfs(cur+1);
        vis[i]=0;
    }
}
int main()
{
    fuck();
    while(scanf("%d",&n)!=EOF)
    {
        printf("Case %d:\n",cases++);
        memset(vis,0,sizeof(vis));
        a[0]=1;
        dfs(1);
        printf("\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: