您的位置:首页 > 其它

HDU 1171 Big Event in HDU

2012-07-29 16:50 387 查看
Problem Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).



Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the
facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.



Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.



Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1




Sample Output

20 10
40 40
题目意思是说有N种物品价值为A的有B件,如第一组数据:2种物品,第一种价值为10有一件,第二种价值为20也是一件,把它们分成两部分,使得第一部分减第二部分的差最小(差大于等于0);解法:背包,我们可以设背包容量为所有物品Value和的一半,因为差最小。01背包就可以用上了。LANGUAGE:CCODE:
#include<stdio.h>
#define maxn 1001
#define max(a,b) a>b?a:b
#include<string.h>
int main()
{
	int value[maxn],num[maxn];
	int f[125000],n,i,j,k,ave,sum;
	while(scanf("%d",&n),n>-1)
	{
		sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&value[i],&num[i]);
			sum+=value[i]*num[i];
		}
		memset(f,0,sizeof(f));ave=sum/2;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=num[i];j++)
			{
				for(k=ave;k>=value[i];k--)
					f[k]=max(f[k],f[k-value[i]]+value[i]);
			}
		}
		printf("%d %d\n",sum-f[sum/2],f[sum/2]);
	}
	return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: