您的位置:首页 > 产品设计 > UI/UE

HDOJ-1297 Children’s Queue[递推+大数]

2012-07-18 21:47 239 查看

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6000 Accepted Submission(s): 1887


[align=left]Problem Description[/align]
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

[align=left]Input[/align]
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

[align=left]Output[/align]
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

[align=left]Sample Input[/align]

1 2 3

[align=left]Sample Output[/align]

1 2 4

[align=left]Author[/align]
SmallBeer (CML)

[align=left]Source[/align]
杭电ACM集训队训练赛(VIII)

[align=left]Recommend[/align]
lcy

别人的解法:
F(n)表示n个人的合法队列
按照最后一个人的性别分析,他要么是男,要么是女,所以可以分两大类讨论:

1、如果n个人的合法队列的最后一个人是男,则对前面n-1个人的队列没有任何限制,他只要站在最后即可,所以,这种情况一共有F(n-1);

2、如果n个人的合法队列的最后一个人是女,则要求队列的第n-1个人务必也是女生,这就是说,限定了最后两个人必须都是女生,这又可以分两种情况:

2.1、如果队列的前n-2个人是合法的队列,则显然后面再加两个女生,也一定是合法的,这种情况有F(n-2);

2.2、但是,难点在于,即使前面n-2个人不是合法的队列,加上两个女生也有可能是合法的,当然,这种长度为n-2的不合法队列,不合法的地方必须是尾巴,就是说,这里说的长度是n-2的不合法串的形式必须是“F(n-4)+男+女”,这种情况一共有F(n-4).

所以,通过以上的分析,可以得到递推的通项公式:
F(n)=F(n-1)+F(n-2)+F(n-4) (n>3)

知道递推公式就不难了- -
code:

import java.util.*;
import java.math.*;

public class Main
{
public static void main(String []args)
{
int n;
int i;
Scanner cin=new Scanner(System.in);
BigInteger []result=new BigInteger[1002];
result[1]=BigInteger.valueOf(1);
result[2]=BigInteger.valueOf(2);
result[3]=BigInteger.valueOf(4);
result[4]=BigInteger.valueOf(7);
for(i=5;i<=1000;i++)
result[i]=result[i-1].add(result[i-2].add(result[i-4]));
while(cin.hasNext())
{
n=cin.nextInt();
System.out.println(result
);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: