您的位置:首页 > 其它

hdu 4252 #想法

2012-07-16 22:42 281 查看

A Famous City

[b]Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 119 Accepted Submission(s): 64

[/b]

Problem Description

After Mr. B arrived in Warsaw, he was shocked by the skyscrapers and took several photos. But now when he looks at these photos, he finds in surprise that he isn't able to point out even the number of buildings in it. So he decides to work it out as follows:

- divide the photo into n vertical pieces from left to right. The buildings in the photo can be treated as rectangles, the lower edge of which is the horizon. One building may span several consecutive pieces, but each piece can only contain one visible building,
or no buildings at all.

- measure the height of each building in that piece.

- write a program to calculate the minimum number of buildings.

Mr. B has finished the first two steps, the last comes to you.

Input

Each test case starts with a line containing an integer n (1 <= n <= 100,000). Following this is a line containing n integers - the height of building in each piece respectively. Note that zero height means there are no buildings in this piece at all. All the
input numbers will be nonnegative and less than 1,000,000,000.

Output

For each test case, display a single line containing the case number and the minimum possible number of buildings in the photo.

Sample Input

3
1 2 3
3
1 2 1


Sample Output

Case 1: 3
Case 2: 2

Hint
The possible configurations of the samples are illustrated below:



Source

Fudan Local Programming Contest 2012

Statistic | Submit | Discuss | Note

Home | TopHangzhou Dianzi University Online Judge 3.0

Copyright © 2005-2012 HDU ACM Team. All Rights Reserved.

Designer & Developer : Wang Rongtao LinLe GaoJie GanLu

Total 0.000630(s) query 1, Server time : 2012-07-16 22:38:48, Gzip enabled
Administration
考虑所有情况,例如:1 0 1;3 2 1 2 3.。。。

/*
想法题:去掉所有“无效”的大楼
*/
#include <stdio.h>
#include <map>
#include <algorithm>
#include <iostream>
using namespace std;

#define N 100001
int a
;
int main()
{
int i,inv,cas = 0,n,j;
while(scanf("%d",&n) == 1)
{
for(i = 0; i < n; ++i)
scanf("%d", a + i);
inv = 0;
if(a[0] == 0)
++inv;
for(i = 1; i < n; ++i)
if(a[i] == 0)
++inv;
else
{
for(j = i - 1; j >= 0; --j)
if(a[j] < a[i]) ///亮点!!!
break;
else if(a[j] == a[i])
{
++inv;
break;
}
}
printf("Case %d: %d\n",++cas,n - inv);
}
return 0;
}
/*
11
3 2 1 2 3 0 3 2 1 2 3
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: