您的位置:首页 > 其它

【hdu - 2058 The sum problem】

2012-07-15 15:37 363 查看

The sum problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9020 Accepted Submission(s): 2759


[align=left]Problem Description[/align]
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.

[align=left]Input[/align]
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.

[align=left]Output[/align]
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.

[align=left]Sample Input[/align]

20 10
50 30
0 0

[align=left]Sample Output[/align]

[1,4]
[10,10]

[4,8]
[6,9]
[9,11]
[30,30]

[align=left]Author[/align]
8600

[align=left]Source[/align]
校庆杯Warm Up

[align=left]Recommend[/align]
linle

// Project name : 2058 ( The sum problem )
// File name    : main.cpp
// Author       : Izumu
// Date & Time  : Sun Jul 15 14:45:01 2012

#include <iostream>
#include <stdio.h>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;

int main()
{
int n, m;
while (cin >> n >> m && n + m)
{
int length = sqrt((double)2 * m) + 2;

while (length)
{
int a = m / length - (length - 1) / 2;
if ((a + a + length - 1) * length / 2 == m && a > 0 && (a + length - 1) <= n)
{
printf("[%d,%d]\n", a, a + length - 1);
}
length--;
}
cout << endl;
}
return 0;
}

// end
// ism
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: