您的位置:首页 > 其它

【hdu - 2602 Bone Collector(动态规划、01背包)】

2012-07-14 10:42 351 查看

Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12318 Accepted Submission(s): 4787


[align=left]Problem Description[/align]
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?



[align=left]Input[/align]
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

[align=left]Output[/align]
One integer per line representing the maximum of the total value (this number will be less than 231).

[align=left]Sample Input[/align]

1
5 10
1 2 3 4 5
5 4 3 2 1

[align=left]Sample Output[/align]

14

[align=left]Author[/align]
Teddy

[align=left]Source[/align]
HDU 1st “Vegetable-Birds Cup” Programming Open Contest

[align=left]Recommend[/align]
lcy

// Project name : 2602 ( Bone Collector )
// File name    : main.cpp
// Author       : Izumu
// Date & Time  : Sat Jul 14 10:03:36 2012

#include <iostream>
#include <stdio.h>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;

#define MAXN 1010

int value[MAXN];
int cost[MAXN];

int dp[MAXN][MAXN];

int n, v;

int max(int a, int b)
{
return (a > b)? a: b;
}

void DynamicProgramming()
{
// init for dp[][]
for (int i = 0; i <= n; i++)
{
for (int j = 0; j <= v; j++)
{
dp[i][j] = 0;
}
}

for (int i = 1; i <= n; i++)
{
for (int j = 0; j <= v; j++)
{
if (cost[i] <= j)
{
dp[i][j] = max(
dp[i-1][j],
dp[i-1][j-cost[i]] + value[i]
);
}
else
{
dp[i][j] = dp[i-1][j];
}
}
}

}
int main()
{
int t;
cin >> t;
while (t--)
{
cin >> n >> v;
for (int i = 1; i <= n; i++)
{
cin >> value[i];
}
for (int i = 1; i <= n; i++)
{
cin >> cost[i];
}

DynamicProgramming();

cout << dp
[v] << endl;
}
return 0;
}

// end
// ism
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: