您的位置:首页 > 其它

poj1018

2012-07-13 23:17 197 查看
Communication System

Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum
bandwidths and prices.

By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication
system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the
price of the device respectively, corresponding to a manufacturer.

Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.

Sample Input
1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110


Sample Output
0.649


Source

Tehran 2002, First Iran Nationwide Internet Programming Contest

#include<iostream>
#include<cstring>
#include<iomanip>
using namespace std;
int device[101][1001];

int main(void) {
int t;
cin >> t;
while (t--) {
memset(device, 0x7f, sizeof (device));
for (int i = 0; i < 1001; i++)
device[0][i] = 0;
int n;
cin >> n;
for (int i = 1; i <= n; i++) {
int m;
cin >> m;
while (m--) {
int b;
int p;
cin >> b >> p;
for (int j = 1; j <= b; j++)
if (device[i - 1][j] + p < device[i][j])
device[i][j] = device[i - 1][j] + p;
}
}
double t = 0.0;
for (int i = 0; i < 1001; i++)
if (1.0 * i / device
[i] > t)
t = 1.0 * i / device
[i];
cout << fixed << setprecision(3) << t << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: