您的位置:首页 > 大数据 > 人工智能

uva 442 - Matrix Chain Multiplication

2012-07-12 19:22 337 查看
Matrix Chain Multiplication

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed
strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n (

), representing the number of matrices in the first part.
The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"


Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary
multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))


Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125


对于此题灰常无语,卡了三天,今天百度了下,雷倒,原来每次只有2个矩阵需要计算,不会出现ABC这种类型。在括号嵌套过程中也不会出现2个以上的连乘,如此这般,就简单很多纯粹的用栈即可,这学期刚学的线性代数,自以为掌握不错,知道矩阵是没有交换律的,但是要实现普通意义上的矩阵乘法真的好麻烦。

#include <stdio.h>

void main()

{char ch,s[1000];

int n,i,j,Matrix,row[27],column[27],Mr[1000],Mc[1000],top;

scanf("%d",&n);

while (n--)

{scanf("\n%c",&ch);

scanf("%d %d\n",&row[ch-'A'],&column[ch-'A']);

}

while (gets(s))

{top=0; Matrix=0;

if (s[1]=='\0') {printf("0\n"); goto there;}

for (i=0;s[i]!='\0';i++)

{

if (s[i]==')')

{

if (Mc[top-1]!=Mr[top]) {printf("error\n"); goto there;}

Matrix+=Mr[top-1]*Mr[top]*Mc[top];

Mc[top-1]=Mc[top];

--top;

}

if ((s[i]>='A')&&(s[i]<='Z')) {++top;Mr[top]=row[s[i]-'A']; Mc[top]=column[s[i]-'A'];}

}

printf("%d\n",Matrix);

there :;

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: