您的位置:首页 > 其它

【As Easy As A+B - 专题训练-排序】

2012-07-10 21:27 316 查看
B - As Easy As A+B
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status

Appoint description: System Crawler (2012-06-25)

Description

These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.

Output

For each case, print the sorting result, and one line one case.

Sample Input

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

Sample Output

1 2 3
1 2 3 4 5 6 7 8 9

// Project name : sort
// File name    : main.cpp
// Author       : Izumu
// Date & Time  : Tue Jul 10 21:11:33 2012

#include <iostream>
#include <stdio.h>
#include <string>
#include <cmath>
#include <algorithm>
using namespace std;

bool cmp(int a, int b)
{
if (a > b)
{
return false;
}
else
{
return true;
}
}

int main()
{
int t;
cin >> t;
while (t--)
{
int n;
cin >> n;
int* a = new int
;
for (int i = 0; i < n; i++)
{
cin >> a[i];
}

sort(a, a + n, cmp);

for (int i = 0; i < n - 1; i++)
{
cout << a[i] << " ";
}
cout << a[n - 1] << endl;

}
return 0;
}

// end
// ism
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: