您的位置:首页 > 其它

HDU 1213 How Many Tables

2012-07-10 09:03 483 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5629 Accepted Submission(s): 2662


[align=left]Problem Description[/align]
Today
is Ignatius' birthday. He invites a lot of friends. Now it's dinner
time. Ignatius wants to know how many tables he needs at least. You have
to notice that not all the friends know each other, and all the friends
do not want to stay with strangers.

One important rule for this
problem is that if I tell you A knows B, and B knows C, that means A, B,
C know each other, so they can stay in one table.

For example:
If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay
in one table, and D, E have to stay in the other one. So Ignatius needs 2
tables at least.

[align=left]Input[/align]
The
input starts with an integer T(1<=T<=25) which indicate the
number of test cases. Then T test cases follow. Each test case starts
with two integers N and M(1<=N,M<=1000). N indicates the number of
friends, the friends are marked from 1 to N. Then M lines follow. Each
line consists of two integers A and B(A!=B), that means friend A and
friend B know each other. There will be a blank line between two cases.

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5

[align=left]Sample Output[/align]

2
4

[align=left]Author[/align]
Ignatius.L

[align=left]Source[/align]
杭电ACM省赛集训队选拔赛之热身赛

[align=left]Recommend[/align]
Eddy
//并查集模板题、刷水题练练手噢噢

#include <iostream>
#include <stdio.h>
#include <string.h>
#define N 1003
using namespace std;
int n;
int f
,r
;
int find_f(int x)
{
if(x!=f[x])
{
return f[x]=find_f(f[x]);
}
return x;
}
void union_set(int x,int y)
{
x=find_f(x);
y=find_f(y);
if(x==y) return;
n--;
if(r[x]>r[y])
f[y]=x;
else if(r[x]<r[y])
f[x]=y;
else
{
f[y]=x;
r[x]++;
}
}
int main()
{
int m;
int T;
int i,a,b;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++)
f[i]=i,r[i]=0;
while(m--)
{
scanf("%d%d",&a,&b);
union_set(a,b);
}
printf("%d\n",n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: