您的位置:首页 > 其它

【hdu - 1303 Doubles】

2012-07-08 19:31 357 查看

Doubles

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2176 Accepted Submission(s): 1509


[align=left]Problem Description[/align]
As
part of an arithmetic competency program, your students will be given
randomly generated lists of from 2 to 15 unique positive integers and
asked to determine how many items in each list are twice some other item
in the same list. You will need a program to help you with the grading.
This program should be able to scan the lists and output the correct
answer for each one. For example, given the list
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

[align=left]Input[/align]
The
input file will consist of one or more lists of numbers. There will be
one list of numbers per line. Each list will contain from 2 to 15 unique
positive integers. No integer will be larger than 99. Each line will be
terminated with the integer 0, which is not considered part of the
list. A line with the single number -1 will mark the end of the file.
The example input below shows 3 separate lists. Some lists may not
contain any doubles.

[align=left]Output[/align]
The output will consist of one line per input list, containing a count of the items that are double some other item.

[align=left]Sample Input[/align]

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

[align=left]Sample Output[/align]

3
2
0

[align=left]Source[/align]
Mid-Central USA 2003

[align=left]Recommend[/align]
Eddy

// Project name : 1303 ( Doubles )
// File name    : main.cpp
// Author       : Izumu
// Date & Time  : Sun Jul  8 19:20:51 2012

#include <iostream>
using namespace std;

int main()
{
int a[1000];
int top = -1;
int num;
while (cin >> num && num != -1)
{
top = -1;
top++;
a[top] = num;
while (cin >> num && num)
{
top++;
a[top] = num;
}

// search it to get the answer
int count = 0;
for (int i = 0; i <= top; i++)
{
for (int j = 0; j <= top; j++)
{
if (a[i] * 2 == a[j])
{
count++;
}
}
}
cout << count << endl;
}
return 0;
}

// end
// ism
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: