您的位置:首页 > 产品设计 > UI/UE

HDU Windows Message Queue

2012-07-08 14:40 239 查看

Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1686 Accepted Submission(s): 637


[align=left]Problem Description[/align]
Message
queue is the basic fundamental of windows system. For each process, the
system maintains a message queue. If something happens to this process,
such as mouse click, text change, the system will add a message to the
queue. Meanwhile, the process will do a loop for getting message from
the queue according to the priority value if it is not empty. Note that
the less priority value means the higher priority. In this problem, you
are asked to simulate the message queue for putting messages to and
getting message from the message queue.

[align=left]Input[/align]
There's
only one test case in the input. Each line is a command, "GET" or
"PUT", which means getting message or putting message. If the command is
"PUT", there're one string means the message name and two integer means
the parameter and priority followed by. There will be at most 60000
command. Note that one message can appear twice or more and if two
messages have the same priority, the one comes first will be processed
first.(i.e., FIFO for the same priority.) Process to the end-of-file.

[align=left]Output[/align]
For
each "GET" command, output the command getting from the message queue
with the name and parameter in one line. If there's no message in the
queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

[align=left]Sample Input[/align]

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

[align=left]Sample Output[/align]

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

[align=left]Author[/align]
ZHOU, Ran

[align=left]Source[/align]
Zhejiang University Local Contest 2006, Preliminary

[align=left]Recommend[/align]
linle
http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2724 //优先队列练习
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <queue>
#include <vector>
using namespace std;
struct node
{
char s[100];
int n;
int p;
int i;
};
struct cmp
{
bool operator ()(const node&a,const node&b)
{
if(a.p==b.p)
{
return a.i>b.i;
}
return a.p>b.p;
}
};
int main()
{
node t;
priority_queue<node,vector<node>,cmp> Q;
char s[5];
int k=1;
while(scanf("%s",s)!=EOF)
{
if(s[0]=='G')
{
if(!Q.empty())
{
t=Q.top();
Q.pop();
printf("%s %d\n",t.s,t.n);
}
else
printf("EMPTY QUEUE!\n");//开始时这忘记写'!'符号,贡献了次WA
}
else
{
scanf("%s%d%d",t.s,&t.n,&t.p);
t.i=k++;
Q.push(t);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: