您的位置:首页 > 其它

hdu 1074 Doing Homework

2012-07-03 10:34 253 查看
Doing Homework

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2846 Accepted Submission(s): 1071

Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.



Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject),
C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.



Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.



Sample Input

2

3

Computer 3 3

English 20 1

Math 3 2

3

Computer 3 3

English 6 3

Math 6 3



Sample Output

2

Computer

Math

English

3

Computer

English

Math

Hint

In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the

word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.





Author

Ignatius.L



简单的状态dp题。

找路径比较麻烦些,因此加一个记录路径的变量。而且要求字典序输出,因此在计算前先按照字典序排序即可。

代码

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

#define INF 999999999

typedef struct
{
    int d,c;
    char s[105];
}Home;

typedef struct
{
    int val;
    int last;
    int time;
}DP;

DP dp[(1<<15)+5];
Home a[20];
int ans[20];

bool cmp(Home x,Home y)
{
    return strcmp(x.s,y.s)<0?true:false;
}

int main()
{
    int T,i,j,n,p,t,k;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for (i=0;i<n;i++)
        {
            scanf("%s%d%d",a[i].s,&a[i].d,&a[i].c);
        }
        sort(a,a+n,cmp);
        for (i=0;i<(1<<n);i++)
        {
            dp[i].last=-1;
            dp[i].val=INF;
        }
        dp[0].last=-1;
        dp[0].time=0;
        dp[0].val=0;
        for (i=0;i<(1<<n);i++)
        {
            for (j=0;j<n;j++)
            {
                if ((i & (1<<j))!=0) continue;
                p=(i | (1<<j));
                dp[p].time=dp[i].time+a[j].c;
                if (dp[p].val>dp[i].val+max(dp[p].time-a[j].d,0))
                {
                    dp[p].val=dp[i].val+max(dp[p].time-a[j].d,0);
                    dp[p].last=j;
                }
            }
        }
        printf("%d\n",dp[(1<<n)-1].val);
        t=(1<<n)-1;
        k=n-1;
        while(dp[t].last!=-1)
        {
            ans[k--]=dp[t].last;
            t=(t & (~(1<<dp[t].last)));
        }
        for (i=0;i<n;i++)
        {
            printf("%s\n",a[ans[i]].s);
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: