您的位置:首页 > 其它

POJ 3664 排序,水题

2012-06-28 16:04 232 查看
Election Time

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5531Accepted: 2998
Description

The cows are having their first election after overthrowing the tyrannical Farmer John, and Bessie is one of
N cows (1 ≤ N ≤ 50,000) running for President. Before the election actually happens, however, Bessie wants to determine who has the best chance of winning.

The election consists of two rounds. In the first round, the K cows (1 ≤
K ≤ N) cows with the most votes advance to the second round. In the second round, the cow with the most votes becomes President.

Given that cow i expects to get Ai votes (1 ≤
Ai ≤ 1,000,000,000) in the first round and Bi votes (1 ≤
Bi ≤ 1,000,000,000) in the second round (if he or she makes it), determine which cow is expected to win the election. Happily for you, no vote count appears twice in the
Ai list; likewise, no vote count appears twice in the Bi list.

Input

* Line 1: Two space-separated integers: N and K

* Lines 2..N+1: Line i+1 contains two space-separated integers: Ai and
Bi

Output

* Line 1: The index of the cow that is expected to win the election.

Sample Input
5 3
3 10
9 2
5 6
8 4
6 5

Sample Output
5

Source
USACO 2008 January Bronze

#include <stdio.h>
#include <algorithm>
const int S=51000;
using namespace std;
struct TT{
int id,v1,v2;
}f[S];
inline bool cmp1(const TT &a, const TT &b){
return (a.v1>b.v1);
}
inline bool cmp2(const TT &a, const TT &b){
return (a.v2>b.v2);
}
int main(){
int n,k,i;
scanf("%d%d",&n,&k);
for (i=0;i<n;i++){
scanf("%d%d",&f[i].v1,&f[i].v2);
f[i].id=i+1;
}
sort(f,f+n,cmp1);
sort(f,f+k,cmp2);
printf("%d\n",f[0].id);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: