您的位置:首页 > 其它

POJ 3041 最小点覆盖 二分图最大匹配(hungary邻接阵)

2012-06-27 11:41 344 查看
二分图由n行(A集)、n列(B集)组成,(x,y)有陨石等价于x∈A -> y∈b 有一条有向边。 消去x行等价于覆盖x这个点。问题转化为求这个二分图的最小点覆盖。

Asteroids

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9839Accepted: 5296
Description
Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of
the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find
the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input
* Line 1: Two integers N and K, separated by a single space.

* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
Output
* Line 1: The integer representing the minimum number of times Bessie must shoot.
Sample Input
3 4
1 1
1 3
2 2
3 2

Sample Output
2

Hint
INPUT DETAILS:

The following diagram represents the data, where "X" is an asteroid and "." is empty space:

X.X

.X.

.X.

OUTPUT DETAILS:

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
Source
USACO 2005 November Gold

//二分图最大匹配,hungary算法,邻接阵形式,复杂度O(m*m*n)
//返回最大匹配数,传入二分图大小m,n和邻接阵mat,非零元素表示有边
//match1,match2返回一个最大匹配,未匹配顶点match值为-1
#include <string.h>
#include <stdio.h>
#define MAXN 510
#define _clr(x) memset(x,0xff,sizeof(int)*MAXN)

int hungary(int m,int n,int mat[][MAXN],int* match1,int* match2){
int s[MAXN],t[MAXN],p,q,ret=0,i,j,k;
for (_clr(match1),_clr(match2),i=0;i<m;ret+=(match1[i++]>=0))
for (_clr(t),s[p=q=0]=i;p<=q&&match1[i]<0;p++)
for (k=s[p],j=0;j<n&&match1[i]<0;j++)
if (mat[k][j]&&t[j]<0){
s[++q]=match2[j],t[j]=k;
if (s[q]<0)
for (p=j;p>=0;j=p)
match2[j]=k=t[j],p=match1[k],match1[k]=j;
}
return ret;
}
int match1[MAXN],match2[MAXN],mat[MAXN][MAXN];

int main(){
int n,k,i,j,x,y;
scanf("%d%d",&n,&k);
for (i=1;i<=k;i++){
scanf("%d %d",&x,&y);
x--;y--;
mat[x][y]=1;
}
/*    for (i=0;i<n;i++){
for (j=0;j<n;j++) printf("%d ",mat[i][j]);
printf("\n");
}*/
printf("%d\n",hungary(n,n,mat,match1,match2));
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐