您的位置:首页 > 其它

HDOJ-1010 Tempter of the Bone

2012-06-22 17:16 295 查看

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35460 Accepted Submission(s): 9511


[align=left]Problem Description[/align]
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

[align=left]Input[/align]
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

[align=left]Output[/align]
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

[align=left]Sample Input[/align]

4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

[align=left]Sample Output[/align]

NO YES

//回溯算法
/*
//代码一:输出结果错误,我对比了好几天,就是找不住原因,先放放吧!路过的求指点。。。。
#include<stdio.h>
int m,n,endi,endj,time,escape;
int dir[4][2]={{-1,0},{0,1},{1,0},{0,-1}};
char maze[9][9];

void DFS(int i,int j,int t)
{
int k,temp;
if(i<0||i>=n||j<0||j>=m)
return;
if(i==endi&&j==endj&&time==t)
{
escape=1;
return;
}
if(escape)
return;
temp=time-t-abs(i-endi)-abs(j-endj);//剪枝
if(temp<0||temp&1)//剪枝,如果是奇数也不行,假设当time-temp时候正好到达终点,
return;            //让再走temp时间再回到终点,只有temp为偶数时候才满足题意
for(k=0;k<4;++k)
{
//    if(i+dir[k][0]<0||i+dir[k][0]>=n||j+dir[k][1]<0||j+dir[k][1]>=m)
//        return;
if(maze[i+dir[k][0]][j+dir[k][1]]!='X')
{
maze[i+dir[k][0]][j+dir[k][1]]='X';
DFS(i+dir[k][0],j+dir[k][1],t+1);
maze[i+dir[k][0]][j+dir[k][1]]='.';//回溯---退回时恢复现场
}
}
return;
}

int main()
{
int i,j,sti,stj,wall;
while(scanf("%d%d%d",&n,&m,&time)&&n||m||time)
{
getchar();//吸收换行符
wall=escape=0;
for(i=0;i<n;++i)
{
for(j=0;j<m;++j)
{
scanf("%c",&maze[i][j]);
if(maze[i][j]=='S')//标记起点
{
sti=i;
stj=j;
}
else if(maze[i][j]=='D')//标记终点
{
endi=i;
endj=j;
}
else if(maze[i][j]=='X')
++wall;//方便以后剪枝
}
getchar();
}
if(m*n-wall<=time)//剪枝
{
printf("NO\n");
continue;
}
maze[sti][stj]='X';
DFS(sti,stj,0);
printf(escape?"YES\n":"NO\n");
}
return 0;
}
*/

//代码二:AC代码
#include<iostream>
using namespace std;
char maze[9][9];
int x,y,n,desx,desy,temp; // x is row y is cow n is steps
bool escape; //run or not
int d[4][2] = {{0,1},{0,-1},{1,0},{-1,0}}; // stand for four directions

void DFS(int stax,int stay,int step)
{
if(stax>x||stay>y||stay<=0||stax<=0)
return;
if(stax==desx&&stay==desy&&step==n)
{
escape=true;
return;
}
if(escape) return;// cut tree
temp=n-step-abs(stax-desx)-abs(stay-desy);
if(temp<0||temp&1) return;
for(int i=0;i<4;i++)
{
if(maze[stax+d[i][0]][stay+d[i][1]]!='X')
{
maze[stax+d[i][0]][stay+d[i][1]]='X';
DFS(stax+d[i][0],stay+d[i][1],step+1);
maze[stax+d[i][0]][stay+d[i][1]]='.';  // back
}
}
return;
}

int main()
{
int stax,stay;
while(cin>>x>>y>>n&&x+y+n)
{
escape=false;
int wall=0;
for(int i=1;i<=x;i++)
{
for(int j=1;j<=y;j++)
{
cin>>maze[i][j];
if(maze[i][j] =='S')
{
stax=i;
stay=j;
}
if(maze[i][j]=='D')
{
desx=i;
desy=j;
}
if(maze[i][j]=='X')
wall++;
}
}
if(x*y-wall<=n)
{
cout<<"NO\n";
continue;
}
maze[stax][stay]='X';
DFS(stax,stay,0);
cout<<(escape?"YES":"NO")<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: